专 题 |
电脑入门 | 操作系统 | 办公软件 | 电脑DIY | 网页制作 | 等级考试 | 网络专栏 |
会员登陆 | 会员退出
会员注册 | 会员列表
 当前位置:> 网络学院 > 阅读新闻 打印本页


PPPoE + NAT

 时间:2004-3-31 10:38:00
 
  网吧常用的功能,现在的cisco1720都可做到:

电信最近力推的ADSL是一种性能价格比较好的Internet接入方式,适用于只需访问Internet,不需要对外提供服务(如 WWW, Mail等)的场合。ADSL最常见的应用方式是用一台安装了PPPoE客户端软件的PC来拔号作代理服务器,让多台主机同时访问Internet。有的时候该PC的任务也可以用路由器来完成,最低档的2514路由器就能胜任,只要路由器有两个以太端网口即可。当然,还需要有适当的IOS软件,同时支持PPPoE Client和NAT两个特性、需求最低的IOS是“REMOTE ACCESS SERVER”特性集。以2621为例,运行该IOS只需32M内存、8M Flash,文件名为:c2600-c-mz.122-4.T1.bin ,这就是下面配置的运行环境。

  实际运行的配置:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2621
!
enable secret 5 $1$LJV3$jqSDKFMSZiQBAjlnN/
!
ip subnet-zero
ip name-server 202.xxx.xxx.xxx
!
vpdn enable
!
vpdn-group PPPoE
request-dialin
 protocol pppoe
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
speed 10
half-duplex
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username [email protected] password 7 **********
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
no ip http server
ip pim bidir-enable
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
password *****
login
!
end

  在下行速度为2M的ADSL线路上,F0/0上接只一台PC,用蚂蚁下载测试时,峰值速度竟超过300K,不知道是不是蚂蚁有点夸大了。:-) 值得注意的是有的地区需要用chap认证方式,这时相应的指令为:

ppp authentication chap callin
ppp chap hostname [email protected]
ppp chap password **********

  相关调试命令:

no vpdn logging 关闭连接中提示
debug vpdn pppoe-events 检查PPPoE连接建立过程
show vpdn 检查建立的PPPoE连接
debug ppp negotiation 检查PPP参数协商情况
debug ppp authentication 检查PPP用户认证情况


  最近还碰到一个现象,一个网络中VTP Server 是6509,下面的VTP Client交换机有35xx和2924,由于29xx最大同时只能支持64个VLAN,所以当6509上定义的VLAN超过了64个之后,与6509直接相连的2924不能学习到新加的VLAN,但原有VLAN工作正常;而经过35xx连接6509的2924交换机则出现了自动从VTP Client模式转成Transparent模式的现象,除VLAN1之外不通,需要重新启动才能正常工作。如果这些2924交换机上的端口需要加入新增的VLAN,则需要手工修改其上的VLAN定义,删去一些旧的VLAN,增加新的VLAN。


编辑: 木木

 

【】【 】【关闭】来源:铁通呼伦贝尔信息港

 ·上一条:网络协议PPPoE (3-31)
 ·下一条:什么是PPPoE? (3-31)
 相关专题:
 尚无信息
 相关信息:PPPOE的技术介绍
· 什么是PPPoE? (3-31)
· 网络协议PPPoE (3-31)
· PPPOE的技术介绍 (3-31)
╣ PPPoE + NAT 会员评论[共 0 篇] ╠
╣ 我要评论 ╠
姓 名:   密 码:   新人注册
  推荐文章  
- 铁通PPPoE下载和安装教
- WindowsXP自带PPPoE拨
- PPPOE 的安装、设置方
- ADSL MODEM PPPOE的模
- 下载和安装PPPoE虚拟拨
- PPPOE 软件安装说明
- 什么是PPPoE?
- PPPoE + NAT
- 网络协议PPPoE
- PPPOE的技术介绍
热门图片信息
尚无热门图片